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Congratulations on purchasing your new Viso Systems product. Before using this 

product, please read the Safety Information. 

This manual contains descriptions and troubleshooting necessary to install and 

operate your new Viso Systems product. Please review this manual thoroughly to 
ensure proper installation and operation. 

For news, Q&A and support at Viso Systems, visit our website at 

www.visosystems.com 

Other manuals in this series (the latest version can be downloaded from 

www.visosystem.com): 

 

http://www.visosystems.com/
http://www.visosystem.com/
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1. Safety Information  
Warning! This product is not for household use.  

Read this manual before installing and operating the LabInterface. Follow the safety 

warnings listed below and study all the cautions in the manual. If the device is in any 

way damaged, defective, wet, or show signs of overheating, disconnect from the PC 

and contact Viso Systems Service for assistance. Do not install or use the device 

outdoors. Do not spray with or immerse in water or any other liquid. Do not remove 

any covers or attempt to repair the controller or the power supply. Refer any service 
to Viso Systems.  

2. Disposing of this Product 
Viso Systems products are supplied in compliance with Directive 2002/96/EC of the 

European Parliament and of the Council of the European Union on WEEE (Waste 

Electrical and Electronic Equipment), as amended by Directive 2003/108/EC, where 

applicable. Help preserve the environment! Ensure that this product is recycled at 
the end of its lifetime. Your supplier can give details of local arrangements for the 

disposal of Viso Systems products.  

3. Introduction 
The special Viso accessory “LightInterface” is an accessory that can be used with all 
Viso light measurement systems: LightSpion, BaseSpion and LabSpion. 

With LightInterface and standard software features you can regulate light sources 

during a test. This means that you can measure for example efficacy results, flicker or 
chromaticity for a lighting fixture in several setting and collect the results in one 
report. 

LightInterface handles protocols DMX/RDM, DALI DT8 and 0-10 V. The system also 
allows for measuring wireless systems with some manual interaction. 

LightInterface integrates seamlessly with Viso Light Inspector software 

LightInterface facilitates measuring stand-by power consumption. 

4. Product Dimensions 
Length 180 mm 

Width 75 mm 
Height 52 mm 
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Front side:

 

Rear side:

 

LightInterface is powered by USB. 24V is optional/for future use (no DC power supply 
is included).  

“Special” button is for internal Viso use. 

5. Packages and Weight 

Shipping Packages Shipping Dimensions Shipping Volume Weight 

1. LightInterface 200 x 118 x 77 mm 0,0018 m3 1,00 kg 

 

Total shipping weight: 1,00 kg. 

Internal foam packaging. External cardboard packaging. 

The shipment is done in a total of 1 package 

6. LabInterface Package Content 
▪ 1 LabInterface Unit 

 

▪ 2 m USB Cable 
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7. LightInterface Installation Procedure 

7.1. Hardware setup 

When connected you will see a small green indicator  in the upper 
right corner of the Control device configurator window. 

Connect like this to your measurement PC with Viso Light Inspector installed (2 USB 
cables): 

 

Or use as powered USB hub as intermediate (1 USB cable to measurement PC): 
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8. Software Setup and Measurements 

8.1. Introduction and measurement principles 

 

STEP 1: Test definition 

To run a measurement including controls you need to define: 

1) Device configuration 

Set up your DMX or 0-10 V light source and assign functions (e.g. Dimming, 

red, green, blue, white) to the available channels. 

As Dali DT8 is a predefined protocol, no setup is needed. 

The system handles wired controls with protocols DALI, DMX/RDM and 0-

10V. 

2) Control sequence 

a. What settings would you like to use for the main measurement 

step? 

b. What functions do you want to control and in which steps? 

c. Do you want to control one or two parameters (e.g., dimming 

and color tuning)? 

d. How much time will you reserve for stabilization in between 

control steps and what threshold? 

e. Should the LabSensor set the integration time for each step? 

f. Do you wish to measure flicker for each step? 

3) Choose a combination of a device and a control sequence 

a. The system will verify that all the functions configured in the 

control sequence are available with the selected device. 

 

It is also possible to use other control methods than what is supported by the 

LightInterface by selecting “Manual” device type in the configuration menu. The 
system will then prompt the user to change settings for each measurement step. 

STEP 1

Test definition

• Setting up the 
combination of 
device and control 
scheme

STEP 2

Main measurement

(3D)

• Running one normal 
measurement in a 
specific control 
setting

STEP 3

Control sequence 
measurement

(point)

• Running 
measurements in 
your predefined set 
of control steps 

STEP 4

Saving and outputs
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STEP 2: Main Measurement 

In this step, the system runs a normal 3D light distribution measurement with the 

resolution etc. you have chosen.  

The parameters configured in the “Main measurement parameters” section of the 
Control Sequence you have selected will be applied upon starting the measurement. 

If you set e.g. color temperature as one of these parameters, and the setting is then 

subsequently not used as one of the two configurable parameters, this setting will 

remain static during the control sequence measurement. 

STEP 3: Control Sequence Measurement 

When the main measurement is finished, the system will automatically move to the 

position (vertical and horizontal) where the highest intensity was measured, and step 

through the parameters defined in the control sequence.  

The system will not make distribution measurements at each step, as this would 

significantly slow down the measurement time. Should you require this, parameters 

can be set manually in the Device Configurator (window with faders for manual 

control), and separate distribution measurements can be performed as ordinary 
measurements with the control sequence disabled. 

As the measurements at each step are only point measurements, spectra and color 

metrics for each of the steps are only measured for the peak angle as opposed to in 

the main measurement, where they are based on the integrated (average) spectrum 

for the entire distribution. This means that if the lamp has a significant spectral 

variation at different angles, these results should be used with caution. 

Fortunately, it is possible to verify this by making a distribution measurement with 

the settings you wish to test and going into ‘Measurement ‘ -> ‘Measurement planes’ 

where you can move through the angles and planes to see the spectral and 

colorimetric variation. 

Like the spectral variation, the relative distribution of the lamp should also be 

verified at relevant settings (e.g., different LEDs), as the lumen results for each step 

are scaled to the distribution and peak output from the main measurement. This is 

easily done by making a distribution measurement of the relevant settings (e.g., red 

LED 100% on) and then comparing it to e.g. green LED 100% on. 
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STEP 4: Saving and output 

After the control sequence measurement is completed, it will present the result to 

you graphically. If you hover over the small spectra, you will get more measurement 
details: 

 

Note: Some results will be ‘NaN’ until the measurement is complete.  

Save the measurement. All control sequence results are stored in the same fixture 
file.  

This also means that you can always return to the Control sequence results window 
and generate comprehensive result reports based on a single fixture file. 

As usual, you may define custom PDF/CSV/XLS outputs that allow you to analyze or 

present your output in several ways. 

Demo pdf report templates are available as self-installing plugins here: 

https://www.visosystems.com/download-plugins/  

 

https://www.visosystems.com/download-plugins/
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8.2. Configuring a new control device 

This paragraph describes how you can prepare the software for measuring a new 

light source with specific settings (= a control device). If you have many devices that 

share the same settings/profile, this configuration can be saved as a template and 
reused. 

Go to Setup → Control device configuration  

 

This window allows you to pick the relevant measurement protocol – DALI, DMX or 
0-10V: 

 

DALI devices: 

 

Click ‘Discover devices’ to explore the connected device and its control ranges. 
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DMX Devices: 

 

You may pick your previously created devices from the drop-down list and edit them 

or make a new configuration by clicking . 

To configure a new device, assign functions to the channels of your choice. The 

buttons between channels are used to combine two 8-bit channels into one 16-bit 

channel. All 512 DMX channels are available. 

 

Custom channels can be used to set e.g. tilt or pan of your dmx lamp, to ensure 
correct settings for every measurement. When assigned, add this parameter to the 

“main measurement parameters” in the control sequence, and type in the DMX 

value directly (0-255 or 0-65535). 

Give the device a name and save the new device. 
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0 -10 V devices 

 

There are four 0-10 V channels to work with. 

Functions are assigned like with DMX. 

Deleting saved devices 

Device configurations are saved to your standard measurement folder (defined in 

Setup → Options → Tab: Basic. DMX device definition file names end with 

“.DmxDeviceSetup” and similar for 0-10 V devices. 

To delete these device configurations, simply open a file browser and find the files 

that you want to delete. 
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8.3. Creating a new control sequence 

This paragraph describes how you prepare the software for measuring a new control 

sequence. If you want to reuse the control sequence, this configuration can be saved 
as a template and reused with any device that has the used functions. 

Go to Setup → Control sequence setup:  

 

This window opens 

 

 

This part of the window contains your 

saved control sequences.  
You may pick a existing sequence from 

the list and edit it, or make a new by 

clicking  
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In this part of the window of you can do 
the following: 
• Define your control protocol name 

and save it to the list above.  

• Choose if you want to add flicker 

to your data collection by clicking 
the “Measure flicker” button 
on/off. 

See more information on page 18. 

• Choose whether you want to allow 

the system to auto-set integration 
time for each step by clicking the 
“Auto-set integration time” button 

on/off. 

• Choose your stabilization criteria 

for each step of the control 
sequence (stabilizing the light 
source before the main 
measurement runs independently 
as a part of the standard 

measurement start-up procedure). 
Here you can set a combination of 
Max. variation in % and period to 
check. 

▪ If you want the step to be 
measured when the intensity 
has not changed more than 

1% in the preceding 5 
minutes, set to 1% and 5 
minutes.  

▪ If you want all control 
sequence measurements to 

be separated by a 10-minute 
stabilization period, set to 
100% and 10 minutes. 

 

In this area you must define the control 

parameters that should be used in your 
main measurement (the distribution 
measurement performed before the 
control sequence is measured) 
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In this area, you may set up measurement steps for one or two control parameters.  
Each can be set to: Dimming, CCT, Colors (red / green / blue / white / amber / Free 
/ UV / CIEx / CIEy/ Custom 1-10) – whatever is configured in your device. 

Each parameter can be measured in a range of steps. You must define the number 
of steps, the range, and the distribution (linear, logarithmic, or manual). Manual 

distribution could be relevant if you want to test at specific color temperatures like 
2700/3000/2500/4000/5000 or similar. 

 

In this area, you can see the steps that 
will be measured graphically. The 
matrix illustrates your sequence – 
choice of parameter setpoints and 
combinations. Each ‘x’ represents a 
measurement. 

 

In parallel, this window illustrates the 

estimated total measurement time 
estimates based on the sequence 
settings. 

When all of the above is defined, please remember to save the protocol. 
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Deleting saved protocols 

Go to Setup → Control sequence setup. Right-click on the line in the control 

sequence browser on the line that you want to delete, and click ‘Delete’. 

Alternative: 

Protocol definitions are saved to your standard measurement folder (defined in 

Setup → Options → Tab: Basic. File names end with “.ControlSequence”. 

To delete these definitions, simply open a file browser and find the files that you 

want to delete. 

8.4. Starting a new measurement including a control scheme 

Open the Light Inspector software (beta version 7.14 or later). 

You may set up your controls first, or set everything up when starting a new 
measurement. 

The following explains the first of these approaches. 

Defining a device and a control sequence 
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Starting a new measurement with controls 
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9. Adding TLA measurements 
TLA measurements with Viso LabFlicker can be part of your control sequence results. 

In this way, you can also investigate how dynamic control influences TLA metrics  
such as Flicker Frequency, Percent Flicker, Flicker Index, SVM, and PstLM. 

As opposed to the spectrometer sensor, LabFlicker has a limited dynamic range, and 

is therefore dependent on being in a suitable distance. If one of your control 

parameters is dimming or if the parameter significantly changes the output of the 

lamp, it is necessary to find a distance that is suitable for both ends of your dimming 

range before starting your measurement. Further, the LabFlicker must be placed in a 

position that ensures that is not casting a shadow on the sensor - no matter how the 

light source is turned during measurement, LabFlicker should not obstruct any light 

from hitting the sensor. 

With newer model of LabFlicker (that have a higher dynamic range), the ideal 
position is often directly on LabDisc: 

 

In this way, the LabFlicker stays close to the photometrical axis without casting 
shadows. 

If the signal was too low or too high during the control sequence, the software will 
either give a result with a warning or no result at all. 

9.1. Optimizing the LabFlicker position 

Before starting a control sequence measurement, please optimize the LabFlicker 
position: 

• Move your sensor to the optimal distance (Go to Help → Sensor Distance 

Guide): Minimum distance or slightly above. 

• Turn on the light source and adjust the output to the minimum dimming 

output of your control matrix. You may have to adjust both color and 

dimming to find the minimum. 

• If you own a LabDisc, attach LabFlicker to the front of the stem with the 

original rubberized magnet and/or with tape, and check whether the signal 
is strong enough. If not, proceed to the next step. 

• Put your LabFlicker on a tripod and move it to a spot in the vicinity of the 

luminaire where the signal is “ok” = slightly over minimum. Make sure that 

LabFlicker is not in the sensor field of view, i.e., shading light in any 

position also when the light source is rotating. 

• Proceed to measuring. 
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10. Wireless protocols – manual mode 
This feature is available even if LightInterface is not connected. It allows users to use 

control sequences (following normal measurement) by manually regulating the 
device in between measurement steps. 

In manual mode, the system will prompt the user to regulate the device by any 
means, such as wireless control (Bluetooth, WIFI, Zigbee, etc.): 

• Click ‘Start Measurement’  

• Choose number of planes etc. 

• Click ‘More settings’ 

• Click ‘Setup’  

• Under Device type, select ‘Manual’ 

• Under control sequence, pick a predefined control sequence from the 

drop-down list, or define a new sequence with  

• Click ‘Apply’ 

• Click ‘Enable’ 

 The system will then perform a normal measurement followed by a control 

sequence where the user is prompted to make regulations with pop-up windows like 
this: 
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11. Results presentation in the software 
To see all control results, go to View → Control sequence results 

11.1. Measurement table view 

Click View → Control sequence results →Tab: Measurement table: 

 

This window displays the number of control steps that were performed as a matrix (2 

dimensional or single). In this view, you will just see a small spectrum image that 

represents each control step. 

As during the live measurements, you can see more detailed results by hovering over 

the cells in the matrix: 
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Explanations to each section of this window: 

 

The control settings for the particular step. 

“Actual value” is the value sent to the device 
(e.g., DMX value 255 or Dali value 254) 

 

Photometric properties: 
The scaled luminous flux (light source total) 
can be scaled using the peak intensity:  
 

𝑆𝑐𝑎𝑙𝑒𝑑 𝑙𝑢𝑚𝑒𝑛𝑠𝑡 𝑒𝑝 = 𝐹𝑙𝑢𝑥𝑚𝑎𝑖𝑛

𝐼𝑛𝑡𝑒𝑛𝑠𝑖𝑡𝑦𝑠𝑡𝑒𝑝

𝐼𝑛𝑡𝑒𝑛𝑠𝑖𝑡𝑦𝑃𝑒𝑎𝑘 ,𝑚𝑎𝑖𝑛

   

 

Below you will see an image of the spectral 

intensity distribution in the peak intensity 
direction at the specific control step1 

 

Color properties1: 
 
CRI – Color Rendering Index 

TLCI – Television Lighting Consistency Index 
TM30 Rf – IES TM30 fidelity index 
TM30 Rg – IES TM30 gamut index 

CQS – NIST Color quality scale 
CIE 1931 x,y – CIE color coordinates 
 

 

Power properties: 

 
Efficacy and Efficiency 

Voltage and Current 
Power 
Frequency 

Power Factor (PF)  
Displacement Factor (DPF) 
Total harmonic distortion: THD (V) and THD 
(I) 

 
 
 

Flicker properties (only if LabFlicker was 
connected, and flicker selected in the 
protocol): 
 
Frequency 
Percent Flicker 
Flicker Index 

SVM (stroboscopic effects 80 < 2000 Hz) 
PstLM (visible flicker < 80 Hz) 
 

As the distance between the light source 
and LabFlicker is critical, you may get a 

warning that the signal was either too low 
(bad signal-to-noise ratio) or too high 
(oversaturated). Also see page 18. 

 
1 Please note that color properties may vary from the integrated spectrum (weighted average 
spectrum for all directions). 
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11.2. Measurement graph view. 

Click View → Control sequence results -> Tab: Measurement graph: 

In this view you can see graphical representations of the control sequence data. The 

default graph shows the measured intensity versus the target dimming level.  

Hover-over effect: Try mouse hovering over the “+” data markers and you will find 
more results. 

Other standard options can be found in the drop-down list: 

 

Click Settings, and you will have the option to change  

• Data selection 

• Legend location 

• Scaling on axes 

To see the effect of your selections, click ”Generate plot”. 
The in-software graphical tools are for analysis only and cannot upon launch be 

printed or saved directly from here. See more details in the next section. 
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12. Reporting 
All results can be exported both as Excel and XML reports and in customizable PDF 

reports. 

Standard control sequence output in Excel/XML 

Go to File → Export → Control sequency results → Excel (xlsx) (or XML) to get all 

control sequence data outputs collected in a spreadsheet or data format. 

 

Standard PDF reports 

You may find PDF templates that you can work with in 

https://www.visosystems.com/download-plugins/ . 

These templates self-install: Download the plugin, and double-click on the plugin file 
in your file browser, and the plugin self-installs to become available as a standard 

PDF report in Light Inspector: 

There are two templates available: 

   

https://www.visosystems.com/download-plugins/


 

 
 

 

 

 
25   

 

Building your own customized reports 

It is possible to build your own customized PDF, Excel and CSV reports using the 

following {KEYWORDS}: 

 

Keyword Use Example 

{CONPARNAME#} Control sequence 
parameter name and unit 
(if any).  
 

To get the name and unit 
of Parameter 1, write 
{CONPARNAME1} 

If you have chosen to (1) 
control dimming and (2) 
color temperature, using  
{CONPARNAME1} will 

output “Dimming (%)”. 
 

{CONPARCOUNT#} Number of steps for each 
control sequence 
parameter. To get the 
number of values for 
parameter 1, write 
{CONPARCOUNT1} 

If you have chosen to 
measure in e.g., five 
dimming steps (20%, 40%, 
60%, 80% and 100%), 
using {CONPARCOUNT} 
will output “5” 

{CONPAR#} Control sequence 
parameter value.  

To get the third value of 
parameter 1, write 
{CONPAR1-3} 

If you have chosen to 
measure in e.g., five 

dimming steps (20%, 40% 
,60%, 80% and 100%), 
using {CONPAR1-3} will 

output “60%” 

{CONRES#} Control sequence result. 
Formatted so that one can 
get fx the light intensity in 

position 2,4 in the 
measurement matrix by 

writing \"CONRES-
Intensity-2-4\". Optionally 
specify unit by adding eg. 

@W/sr to the result name 
like so \"CONRES-

Intensity@W/sr-2-4\". For 
the complete list of 
available outputs, see 

Help -> Control sequence 
result options 
The complete list of 
OutputOptions are listed 
below. 

If you have chosen to 
measure in e.g., five 
dimming steps (20%, 40% 

,60%, 80% and 100%), and 
e.g., three CCT steps 

(2700, 4000, 6500), using 
{CONRES-Intensity-2-4} 
will output e.g. “368” 

being the intensity 
measured in that specific 

control setting.  
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Output Options   

Parameter_1_value 
Parameter_2_value 
Target_Dimming_Level 
Target_Color_Temperature 
Target_x_coordinate 
Target_y_coordinate 
Target_R 

Target_G 
Target_B 
Target_W 

Target_A 
Target_F 
Target_UV 
Target_Custom_1 
Target_Custom_2 

Target_Custom_3 
 

Target_Custom_4 
Target_Custom_5 
Target_Custom_6 
Target_Custom_7 
Target_Custom_8 
Target_Custom_9 
Target_Custom_10 

Intensity 
Scaled_Lumen 
Color_Temperature 

x_coordinate 
y_coordinate 
Duv 
CRI  
TM30_Rf 

TM30_Rg 
 

CQS 
Power 
Voltage 
Current 
Power_Factor 
THD_Voltage 
THD_Current 

Scaled_Efficacy 
Scaled_Efficiency 
Flicker_Frequency 

Percent_Flicker 
Flicker_Index 
SVM 
PstLM 

 

Output example – table: 

 

13. Adding Control Sequence Results to LDT 

Files 
LDT files can contain more than one lamp. This is because LDT files were deviced 

when most indoor fixtures could contain more than one lamp type with different 
outputs and wattages. 

This feature can be used to convey your control sequence results to users of LDT 
files, the lighting designers. 

Go to Setup -> Optional -> Tab:Export.  

Click ‘Edit LDT template’. 

{CONPAR1-7} 

Output Option 

{CONPARNAME1} 

{CONPARCOUNT1} 

{CONPARNAME2} 

{CONRES-CRI-4-2} 

{CONPAR2-3} 
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These are the six lines that can be repeated to contain all of your control sequence 

results – provided that you design a special LDT template containing the right 
number of repetitions. 

Pull the information that you need with lines like this (/0 means no decimals): 

  

Continue repetitions until you have covered of all the combinations in your 
measurement matrix. 

Click ‘Save’ and pick a new name if needed. Read more about the LDT format in page  

Error! Bookmark not defined.. 

 

14. Using LightInterface for manual 

experiment 
When you have LightInterface installed, you may also use the Light Inspector 

software for manual inspections and experiments: Once the communication with 

your device is established, the software offers means of adjusting your light source in 

any way that you wish using sliders. You will see the effect of your manipulations 
directly on the light source. 

Starting live readings with the spectrometer sensor with the ‘Start spectra scan’ 

button , means that you can also get live reading of intensity (in cd or W/sr), 
color metrics CCT, CRI, etc.  

Hence you can use the system for instance check which color mix that will provide a 
given CIE x,y, or how much amber color you need to add to bring the CRI up to 85. 
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15. Technical Specifications 
Power and data  USB B data and power connection  

Dimensions L*W*H 180 mm * 75 mm * 52 mm 

Materials  Powder coated steel housing 

Weight  600 g 

Connections DMX/RDM RJ45 

DMX/RDM 3-pin 

DMX/RDM 5-pin  
DALI DT8 

0-10V (4-channel) 
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At Viso Systems we design, develop and manufacture OEM- and customer-specific 

goniophotometer solutions. Our mission is to support customers with powerful and 

yet easy to use control measurements solutions. Products are developed and 

manufactured in Copenhagen, Denmark. 

 

 

 

 

 

 

 

 

 

 

 


